
 

TSLOPE   

Tutorial – starting with a 2D slope model and extending to 3D 

 

 

1.  Introduction 

 

TSLOPE is a slope stability analysis package that has been developed around a fully 3D 

model of a slope.  The analyses that can be carried out may be either 3D, or 2D, with the 2D 

sections aligned in arbitrary user defined directions through the model. 

 

It is expected that many TSLOPE users will have access to programs that can be used to 

develop a 3D geological model that will be used to constrain the 3D slope model. Importing 

surfaces from other programs to TSLOPE is a simple matter using common file formats. 

 

However, some TSLOPE users may only have a 2D representation of their slope problem, 

and need to be able to transfer the relevant geometry into TSLOPE. 

 

A problem that is initially defined in 2D can also be readily expanded to 3D. This tutorial is 

designed to help with understanding this process. 

 

As TSLOPE works in a 3D world, all points will have x, y and z coordinates. Therefore when 

you are working in 3D, surfaces are referred to as ellipsoids or spheres (the equivalent of 

ellipses or circles in 2D).  If you start with a 2D representation of your slope problem, the 

TSLOPE model will always have a width that you can specify, in the y direction. 

 

TSLOPE is able to handle real world coordinate systems, with a large number of significant 

figures attached to each coordinate. TSLOPE may simplify the displayed values for purposes 

of legibility.  

 

 

2.  2D Slope Example 

 

The slope problem that we are going to set up in TSLOPE is an example that has been 

described by Duncan et al. (2014)1.  It is their Example 3:  Excavated slope in stiff-fissured 

clay, as described by Skempton and LaRochelle (1965)2, a deep excavation in the London 

Clay at Bradwell. 

 

The geometry of the excavation and the layers forming the slope are shown in Figure 1. 

 

                                                 
1 Duncan, J.M., S.G. Wright, T.L. Brandon 2014  Soil strength and slope stability (second edition) John Wiley 

& Sons, Inc.  317pp 
2 Skempton, A.W. and LaRochelle, P. 1965 The Bradwell Slip: A short-term failure in London clay.  

Geotechnique 15 (3); 221-242 
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Figure 1.  Cross section of excavated slope, after Duncan et al. (2014) Figure 7.13. 

 

 

The materials in the slope have the following properties: 

 

 

Material Unsaturated 

density 

Saturated 

density 

cohesion Friction 

angle 

     

Clay Fill   110 pcf 0 0 

Marsh Clay   105 pcf 300 psf 0 

London Clay   120 pcf Varies from datum 875 psf at 

-3 ft with gradient of 65 psf/ft 

to maximum of 3000 psf 

0 

 

Table 1.  Material properties. 

 

 

3.  Setting up TSLOPE 

 

Open TSLOPE by clicking on the icon on your desktop 
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This opens a new project as shown on the next figure.  There are menu items down the left-

hand side, and a Project pane where a graphical representation of the slope model will be 

shown. 

 

 

 
 

 

We will work down each item in the directory tree panel, starting with the first item - Title & 

Description.   The labelled panels Title: and Description: below the menu tree are shown, 

and are open for data entry. 

 

 

In Title:, we will put     Duncan et al. 2014 Example 3 

 

In Description:, we will put    Excavated slope in stiff – fissured clay   
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We can use the Description: box 

to add any other useful 

information related to this 

TSLOPE project file. 



  

  

 

5 

TSLOPE 2D – 3D Tutorial 1.2  July 2017 

Now that we have some data entered, it is good practice to save our work.  From the File tab 

choose Save As … and provide an appropriate file name and directory for the project file to 

be saved. 

 

TSLOPE saves project files with a .tsz extension. 

 

While at the top of the TSLOPE active window, check out the various options that are 

available as shown below: 

 

 
 

 

Under the File tab, you will see the following: 

 

 
 

 

While you are working with TSLOPE, a report is being compiled in the background.  That is 

in HTML format, giving your flexibility in adapting the report to your own format.  Using 

Print Preview Report.   As you get different graphic views of your project, you can add them 

to the report by clicking on the camera icon shown towards the top of the TSLOPE active 

window. 

 

These images are collected and available for review from the Report Snapshots panel at the 

bottom of the window. 

 

The next menu item is Preferences.  This opens a panel with default values that we may need 

to change: 
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4.  Entering slope data 

 

The Materials menu shows a Default tab already set up.   Selecting Default we open a panel 

with the following: 

 

 

The defaults are shown, we will 

need to make some changes as 

we are working in units of feet 

and pounds 

We will left click on the right tab 

to pull-down the menu item U.S. 

Customary, and set this for the 

project units. 
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Sometimes the user will want to leave the default label intact - for instance if there is only 

one material in the problem – but normally the user will want to overwrite the default label 

and properties with his/her own choices. 

 

In this case we need to input the appropriate values for the three layers, as given in Table 1.  

Starting with the first layer in the stratigraphy: 

 

 

 
 

 

TSLOPE requires that a total unit weight be specified for both saturated and unsaturated 

conditions.  In this example there is no phreatic surface and all materials are presumed to be 

unsaturated so we just specify the same value for the saturated unit weight. 

 

To add the next material, go back to the Materials menu and right click on the mouse to open 

the tab for Add Material… 

 

The Material Id is used internally 

and provides an alternative label 

should the user not provide input 

into the Label field 
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The Material pane then comes up with: 

 

 

 
 

We make appropriate changes: 
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We then add a further material, for London Clay  

 

 

 
 

 

 

 

We set the appropriate unit 

weights, and use the pull-down 

tab to choose Cohesion function - 

Varies from datum 

We fill in the appropriate values 

from Table 1 in the Mohr-

Coulomb panel 
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The next menu item, Surfaces, allows us to begin to define the geometry of the slope 

problem. 

 

 

 
 

 

We will open the Top menu option by right mouse click, and we get the following: 
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We then select Add Extruded Section…  and automatically generate a simple 3D surface. 

This is initially a horizontal plane, with the parameters shown in the panel.  We are at present 

only interested in the 2D cross section through this surface but the program calls it an 

“extruded” section because the 2D section is automatically extruded to 3D and we are set up 

to use the model in a 3D slope stability analysis at a later point. 
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The Project panel now shows the surface with a top down view (X – Y axes).    
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Using the mouse buttons, the plane can be rotated, panned, and zoomed as required.  Left 

mouse is for rotation, centre mouse for dragging, right mouse for zooming. 
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Or, more usefully it can be viewed in 2D by going to the View pull-down menu and selecting 

another view, normally S> N. 

 

 

We then need to make appropriate changes to the Extruded Section parameters: 

 

 

Unlocking the Extruded Section Geometry 

changes the display in the Project panel: 

 

 

Change the Label to a suitable 

one for the slope 

Uncheck the Is locked box 

Set the Z Origin to 0 and Overall 

width (ft) to 200.  Then from the 

Points box, mouse click on the 

button to the right to activate the 

edit profile points menu 



  

  

 

15 

TSLOPE 2D – 3D Tutorial 1.2  July 2017 

 
The solid balls can be moved by the mouse to alter the width and orientation of the plane.   

However we will use the Edit Profile Points menu so that we can add new points, and have 

precise control of our changes. 

 

The Edit Profile Points menu pops up in the Project panel.  It can be moved and expanded as 

necessary. 
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Because we are working from a 2D representation of the slope we can align the section with 

the X Z axes.   TSLOPE sets the positive Y axis oriented to the “north” of the model.  Z is 

always positive in an upward direction.   

 

 

 
 

 

 

We mouse click on OK, and the Project view changes to show the 3D view of the excavated 

surface.   We need to check the Is Locked box again to ensure that we don’t inadvertently 

move the surface relative to its origins when viewing the 3D graphics. 

 

 

 
 

 

Using the Add button, we input 

the X Z coordinates for all the 

points where there is a changes in 

slope. 
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The next step is to right mouse click on Layers and follow a similar process we have been 

through for the Excavation surface. 

 

 

 
 

 

We expand the Layers menu to show the new Layer Extruded Section 1 

From the Layers menu item we 

select Add Extruded Section … 
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We unlock the Geometry check box, and make the appropriate changes to show the top layer.  

In this slope, the uppermost layer is Clay Fill (this was entered as a default value).  To define 

its geometry, we input the coordinates for the top of the layer.   

 

Referring to Figure 1, there will only be 3 points defining the top of Clay Fill coincident with 

the excavation surface, and terminating at the contact with underlying Marsh Clay. 

 

The TSLOPE convention is to enter the layer tops.  The bottom of the layer is then 

automatically defined as the top of the next layer in the negative Z direction.  The lowest 

layer will extend below the limit of the model. 
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We can change the Colour to match the colour used in Figure 1.  In this case, we use the RGB 

values (208,182,177).  We also change the Label to Clay Fill.  Note that the Material has 

defaulted to 0: Clay Fill. 

 

As we did with the Top surface, we mouse click on the Points box to open the menu to edit 

and add points to define the Clay Fill Layer. 

 

 

 
 

 

 

 

Following addition of the X Z 

coordinates defining the top of 

Clay Fill, we mouse click OK. 
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Remember to check the Geometry Is locked   box. 

 

 

 
 

The yellow highlighted shape is the top of the Clay Fill layer that we have just entered. 

 

Using the same process, we enter the top of the Marsh Clay, Brown London Clay, and Blue 

London Clay layers. 

 

Make sure that you set the appropriate Material for each of the layers.   The London Clay 

material will be used for both Brown London Clay and Blue London Clay layers.  To keep 

the colours consistent with Figure 1, set the Surface style – Colour  RGB values to 

(167,163.20) for Marsh Clay, (142,115,97) for Brown London Clay, and (46,94,167) for Blue 

London Clay. 

 

We now have the full geometry and material property information entered and we can view 

the 3D model in the Project panel: 

 

To confirm that we have the soil stratigraphy correct, click on the Top – Excavation surface 

menu and in the bottom panel, Surface style, uncheck the Show surface and Show contours 

boxes.   
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If we want to view the model in a section view, we can use the View tab to get the options as 

shown: 

 

 
 

We chose the bottom option S – 

N to get a section view 
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To check the coordinate points move the mouse to a point, and pressing the ‘p’ on the 

keyboard.  The pop up box will give you the appropriate data. 

To go back to a 3D view select View  Top  and use the mouse buttons to move the 3D model 

as required. 

 

 

 

 

The view can be toggled between solid and wire frame by typing w (and s to go back to 

solid). 
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5.  Building a 2D Slope Case 

 

 

Slope Case is the term used to describe the combinations of surfaces, layers and other 

elements that make up a particular slope stability analysis. The Slope Cases can be either 3D, 

or 2D. 

 

To build a 2D Slope Case, we must define a Cross-section.   This is our next task. 

 

From the View tab select Top and view the model in the X Y plane: 
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This is a good view to locate a cross section.   If we want to be able to show the section used 

to generate the model, then we need to orient the section in the X axis direction, at Y=0. 

 

 

From the Cross-sections menu, select Add cross-section… 

 

 
 

The section line will show up as a yellow line with balls at each end of the section.  The end 

point balls can be dragged with the mouse to change the section length, and orientation.  The 

line can also be selected and moved retaining the length and orientation. 
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When the section is in the correct 

location, remember to lock it. 
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Right click with the mouse on the Slope Cases menu item: 

 

 
 

 

A pop up box then appears that shows the Surfaces and other parameters that will be used in 

the analysis. 

 

 

 
 

 

With the mouse, click on OK to accept the values. 

 

We now have another tab alongside the Project tab labelled “2D Slope Case A”. 

 

The Project view is shown in plan view with a new surface created under the Surfaces – 

Basal menu;  It is automatically labelled as “Critical circle 2 for slope 1”. We will change the 

label to Critical circle for Slope Case A. The bottom panel on the left shows that the new 

surface is an Ellipsoid (a circle is a 2D representation of a sphere, which is a special case of 

an ellipsoid). 

 

Select Add 2D Slope… 

In this case, the values that have 

been put in automatically are 

correct.  However, we may want 

to change the Label, and add a 

Description 
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We can change the graphic view, and see how the ellipsoid intersects the 3D model: 
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We then open the 2D Slope Case A panel. 

 

 

 
 

Here we have the 2D cross section that shows the excavation surface.  There is a large circle 

(from the automatically generated basal ellipsoid), and red and purple sliders at each end of 

the circle.  When we set up the Slope Case, there was an option to specify a Basal surface.  

We did not have a basal surface set up in our model, and the default became a critical circle; 

TSLOPE then automatically generated an ellipse that would provide a starting point for a 

search. 

 

Note that the X coordinates shown on the 2D Slope Case view are not the same as the project 

coordinates.  The X displayed is the horizontal offset from the origin of the Cross-section.  

Further details of the Cross-section location can be obtained from the Cross-sections menu 

(start and end points, bearing, length). 

 

We then open the Analysis tab on the menu, and confirm that the Materials definition has 

been set at the Layers option. 
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We then left mouse click on the slider (solid triangle) and drag the sliders to define a grey 

box at either end of the slope to control the location of exit points of the critical circle: 
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As you drag the sliders near the toe of the slope, you will get a pop up that allows you to 

Snap to the Toe Point of the slope.  That can be useful, if you know that the basal failure 

surface should be constrained to that point. 

Tip:  If you fumble the slider selection, you may end up with 

a zoom to fill the screen.  To recover, go to the View tab and 

select Zoom Extents to get back to a useful view.  There is 

also a short cut way to do this – use the icon, fifth from the 

left (looks like a magnifying glass). 
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In this case, we accept. 

 
 

The critical circle is now truncated, and will be regenerated once we start the stabililty 

calculations. 
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While we have the 2D Slope Case A tab open, we also get access to the Slope and Analysis 

panels on the left. 

 

Note that there is now a Surface selected for the Basal surface. 

 

 
 

 

 

In the Analysis panel we get the following: 
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We will accept the other default values. 

 

Then mouse click on the Solve button.  

 

You will then enjoy a little animation as TSLOPE iterates to find the critical circle before 

presenting the results: 

 

We need to select Critical search 

Then set Tension Crack TC 

definition to Depth.  For this 

problem the tension crack will 

extend through the depth of Clay 

Fill, so set the Depth (ft) to 11.5 
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Congratulations!   You have carried out a successful 2D slope stability calculation using 

TSLOPE. 

 

The program firstly finds the critical circle for the Ordinary Method, then proceeds with the 

calculations for Spencer’s Method.   We only present the critical circle for the minimum 

factor of safety calculated using Spencer’s Method, and report out the corresponding results 

for Spencer’s Method and the Ordinary Method using that circle. 

 

Remember that TSLOPE compiles a report as you work through the various steps of the 

analysis.  This can be viewed by selecting Print Preview Report from the File menu. 
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The lower left panel gives further information related to the stability calculations: 

 

 
 

 

Note that the factor of safety calculated by Spencer’s and Ordinary Method are the same, and 

close to the results tabulated from other software packages by Duncan et al. (2014). 

 

Full data from the stability analysis can be sent to a .csv file by selecting the Save column 

data as CSV file… option from the Data menu. 
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Following computation of the Factor of Safety, shown by the arrow indicating the direction 

of failure, TSLOPE also displays the calculated line of thrust as a red line.  In this case it is 

located above the failure surface as expected.  TSLOPE also shows the normal stresses acting 

at the base of each slice, as scaled black arrows.  The details of each slice can be obtained by 

positioning the mouse pointer near the base of the slice and using the ‘p’ key to bring up a 

pop up box as shown below. 

 

 

 
 

 

You may not have exactly the same factor of safety that is shown above.  It depends on how 

you have set the limits for the potential slip circle, which is the area shaded in grey. 

 

With the present implementation of TSLOPE, we have not given the user access to the 

parameters that control the minimisation routine.  As a guide, you should make the width of 

the zone between each of the limits as narrow as possible, so long as the exit point of the 

potential slip circle that is calculated is near the middle of the zone you will have a 

satisfactory result.  It is recommended that you try a number of settings until you are able to 

find a minimum factor of safety, but at all times making sure that the circle that you are 

investigating is credible. 

 

For this example, it would seem a good idea to check on other potential modes of slope 

failure. 
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Given the soil stratigraphy, it might be possible for a shallow near surface slope failure to 

occur in the Marsh Clay. 

 

Therefore we will set up another 2D Slope Case to consider that possibility.  We will call this 

2D Slope Case B.    

 

We recommend that you do not change the input parameters in a slope case that you have 

already run as this can lead to confusion.  Set up a new slope case for each variation of the 

problem and the program will keep track of all the cases and results for you. 

 

We will set up the new Slope Case following the steps we used for 2D Slope Case A.  A 

quick way to do this is to duplicate the 2D Slope Case A. 

 

 
 

 

A new Basal surface is created, the Critical circle for slope 2.  We will change the names of 

the Slope Case and Basal surface to Slope Case B. 

 

Move the sliders that define the right-hand exit box for the critical circle so that you cover the 

boundary between Marsh Clay and Brown London Clay. 

 

You will then be prompted to Snap to Toe Point – select Yes. 
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Depending on how you have placed the left sliders to define the box for the exit of the critical 

circle, you might get the following message: 

 

 
 

In this case, you should move the left (red) slider further left until you no longer get the 

message. 

 

 

Select the Solve button, and compare the result with Slope Case A. 

 

 

 
 

 

 

The above results suggests that the top of the London Clay might be a potential slide surface, 

therefore we should investigate a further 2D slope case where we set the Brown London Clay 

layer as a basal surface for the analysis. 

 

This is shown in the Slope panel for a new 2D Slope Case C: 
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When we  Solve this Slope Case, we get the following result: 

 

 

 

Change Define Basal failure 

surface to Basal surface clipped 

by layer 

Select Layer as basal – Brown 

London Clay 
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6.  Building a 3D Slope Case 

 

To build a 3D slope case, we follow the same procedure as with a 2D slope case.  We need to 

make sure that there is a defined basal surface that we can use.  The TAGAsoft developers 

are testing various options for searching for the critical 3D failure surface, but have not yet 

implemented on in TSLOPE.    

 

Reviewing the basal surfaces we have in the project;  these are critical circles used for the 2D 

slope cases: 

 

 
 

 

Mouse click on Critical circle for Slope Case A gives: 

 

 
 

 

We will select the Duplicate option. 

 

 
 

We will then rename the surface. 
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For each of the first three basal surfaces on the list, we will uncheck the boxes Show surface 

and Show contours so they are no longer visible in the Project view. 
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Checking the Basal ellipsoid for 3D slope Case A parameters: 

 

 

 
 

We change the Spherical? box to False 

 

In the Project panel we see a graphical view of the ellipsoid (or sphere).   The coloured balls 

can be selected by left mouse click and moved to change the lengths of the ellipse axes.  We 

will move the black ball to change the Y radius of the ellipsoid. 
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The next graphic shows the sphere modified to an ellipse elongated in the X axis direction. 
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When we have the ellipse with the appropriate geometry, we need to check the Is locked box 

in the Geometry panel. 

 

From the Slope Cases menu item, we Add 3D Slope…  and get the Create new Slope menu: 
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When we select OK, we get a 3D view of the slope showing the discretisation with uniform 

vertical columns.   The columns that overly the basal (failure) surface are shown in the darker 

shade. 

 

There are relatively few columns that will be involved in the stability analysis, so we can 

increase the number of columns to provide a better model without potential edge effects. 

In the Analysis panel, we increase the No. columns/width to the maximum allowed, 200. 

 

 

The default values 

for Surfaces are 

correct, and we can 

change the Label.   
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We then check the Apply button, and the columns are recalculated. 

 

 

 

 
 

 

 

The ellipsoid that we have used to locate the active columns in the stability analysis extends 

beyond the slope, and includes the base of the excavation.  To be consistent with the 2D 

analysis, we need to limit the model to the base of slope. 

 

To do this, we go to the Slope menu and check the Enable clipping box.  We change the 

Enable clipping option from False to True. 
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The graphic view of 3D Slope Case A then changes: 
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Left mouse click on one of the balls at the ends of the axes, and move as necessary to clip the 

model.  As you move the ball, you will see the associated clipping plane move with it.  In this 

example, we need to move the ball located at X=200 Y=0 towards the slope, until the plane 

coincides with the foot of the slope.  The columns at the base of the excavation will then not 

be part of the stability analysis. 

 

When we have the clipping planes in their correct place, we hit the Apply button.   We can 

then turn the clipping planes off from the Clipping is Locked menu item. 

 

 

 
 

 

 

 

Selecting the Solve button, the 3D slope stability calculations are carried out: 

 



  

  

 

49 

TSLOPE 2D – 3D Tutorial 1.2  July 2017 

 
 

 

The graphic output shows the factor of safety (Spencer’s Method), and the direction of 

sliding. 

 

Selecting the View tab and selecting only the View basal surface option, we can then show 

parameters at the base of each column. 
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From the Data tab: 
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The graphic view of the 3D Slope Case A will now show the local factors of safety. That is 

the ratio of resisting to driving forces at the base of each column as calculated using the 

Ordinary Method of Columns. 

 

 

 

 
 

The columns with Local FS less than 1.00 are the driving columns, and the columns with 

Local FS greater than 1.00 are resisting.   

 

This result shows that 3D analysis of a slope with a constant cross-section can make a 

difference, and may be important for your project.  See for instance the case studies provided 

at www.tagasoft.com/case-studies/ 

 

 

http://www.tagasoft.com/case-studies/

